PDA

View Full Version : Anet A8 - Auto level sensor and bed surface setup issues



dfear
01-20-2019, 11:39 PM
Anet A8 - Auto level sensor and bed surface setup issues
---------------------------------------------------------


I am having issues getting this printer to actually print anything now. I have got this printer to print before, but the bed surface wasn't smooth so the print quality wasn't great.


A little backstory:
--------------------
Part 1:
At some point the original masking tape on the heated bed got damaged and I decided to replace it. Also the masking tape wasn't that smooth either. I replaced it with "Wilko Washi" masking tape. Prints didn't want to stick to the bed so I added lots of glue stick glue, which didn't make any difference. At this point I decided to replace the tape with a "Signstek Bed Surface". I am not sure if this bed surface is any good, because I am unable to correctly level the printer; which leads to the next part of the backstory.


Part 2:
At some point I decided that the Z-axis microswitch was too fiddly to adjust, so I wanted to replace it with an Auto-level sensor. It was probably at the point when I ripped the original making tape on the hot bed. I purchased the sensor below. Also I downloaded the "Anet A8 Official" firmware that supports auto-level sensors.


I installed the sensor as per this (https://www.youtube.com/watch?v=3NSDzgZh0Qc) video guide on Youtube. Also I downloaded and installed the firmware (with Auto Level Sensor support) from here. https://www.3dprintersbay.com/anet-a8-a6-firmwares-latest.


Also I found a tip on a video on Youtube which said to use the head of an M10 bolt on each of the corners in order get a basic level starting point before setting up the auto level sensor.


The current problem:
--------------------
I can't seem to setup the auto level sensor and hotbed so that the bed is level and the "nozzle" is at the correct height.


The result is that either the nozzle is too high, which results in the PLA not stick to the bed surface; or the nozzle hits the side of the hot bed and scrapes the bed surface.


SO, HOW DO I SETUP THIS PRINTER? so it prints first time every time and only needs minimal adjustment if the printer is moved to a different location.

Parts, etc:
-----------
1) Auto Leveling Position Sensor for Anet A8 Prusa i3 3D Printer RepRap
https://www.banggood.com/Auto-Leveling-Position-Sensor-for-Anet-A8-Prusa-i3-3D-Printer-RepRap-p-1148521.html


2) Signstek 3PCS 3D Printer Bed Surface for 3D Printer Platform, 220mm x 220mm x 0.5mm (Black)
https://www.amazon.co.uk/gp/product/B072BYSB2Y


3) Wilko Washi Masking Tape Smooth 48mm x 20m
https://www.wilko.com/en-uk/wilko-washi-masking-tape-smooth-48mm-x-20m/p/0454512

TommyDee
01-21-2019, 01:20 AM
Welcome to the forum dfear.

Funny how you locked in on the brand of the tape. I found a perfect tape one time and it had proven to be far superior to other tapes I've tried.
There really is a huge difference in how these crape-tapes are finished on the non-sticky side.

I don't know much about the A8 but is this sensor suppose to maintain realtime leveling or is it intended for maintenance routine where it is calibrated only once?

The way my 3D Systems printer handles auto-leveling is to "map" the surface and compensates Z while printing independent of any further sensing.

Just wanted to put that out there in case you are looking at some logic as to what you are looking at.