View Full Version : OctoPi 0.11.0 available!

02-18-2015, 11:57 AM

As of 13th Feb 2015.
>> Click!


02-18-2015, 02:56 PM
Hi Bolson,

there also 0.12.0 since the 16th.

I have just received my Pi2 and print with Octoprint.
It's fabulous, you upload the gcode from your computer, and you have a total control of the printer from your computer, as well as with your android phone.
You can see the job with the camera...

Top !

02-18-2015, 03:10 PM
Yeah that was on the previous version too (I think?) unless they've made the interface "responsive" to the screen it is opened with?

Where's 0.12.0 then?

02-18-2015, 03:25 PM
sorry, Bolson, I made a mistake
I have downloaded it from nightly directory, perhaps it is not a stable version.

It is a very big change for me, because before that, I only printed with sd card.
I had stop issues with USB.
And to have a control like that is new and impressive.

02-18-2015, 05:10 PM
SO in the end Ethan was right and SOME of you did have issues with the OS/software and not the board!

02-18-2015, 05:34 PM
I tryed on few computer and few OS (win7, win8.1, Mac Os 10.6) but it always stopped after few minutes, it was for that I only printed by USB.
For me Octopi is a revolution.
Sorry for my enthousiasm

02-18-2015, 06:45 PM
Yeah octopi kicks ass, as long as it connects to your board haha

02-25-2015, 08:47 PM
Hello Bolson,

I had few issues when i wanted to print via USB so I only printed by Sd card.
So I bought a Pi in order to try a different way to print and it worked until today.

Now It stops in the first layer as before as if it has com problems.

I have change nothing.

Do you think it could be the board? as you

02-25-2015, 08:51 PM
Hmmmm... not "as me" bc mine never actually "connected" even if the device was seen by the computer...

So besides "stopping on the first layer", can you resume? you need to reset and start over? can you try enabling octoprint logs and post some results here?


02-25-2015, 10:03 PM
It crach the pi, i can't move the mouse.
So i cancel the print with the remote computer.
And I must unplug the pi

When i try to activate log about serial connection, i can check the button to activate it, but the save button doesn't work when i click on this option

I try to reinstal octoprint and I will tell you

02-25-2015, 10:32 PM
IM assuming you're logged as admin onto OCtoprint right?

BTW "Unplug the pi".... did you shutdown first??

02-26-2015, 12:35 AM
I just got my Pi2 and it works fine with Astroprint - but with my Octopi, it doesn;t seem to work with me - did anyone use the .11 version with Octoprint yet?

Or is it just workign with the nighly build?

02-26-2015, 12:50 AM
I guess they may have not compiled the kernel for the Pi2 yet....

02-26-2015, 09:54 AM
OK im wrong, PI2 should be OK working with OctoPi 0.11.0

I just got the Pi2 on my door so I'm swapping the SD card to it and let you know in a minute!

02-26-2015, 10:09 AM
OK i just swapped the SD card from the PI1 to the PI2 and everything loads fine....and fast as hell! wohooo!!

02-26-2015, 10:32 AM
Hi Bolson,

I have installed octopi 11 because I was with the 12 version (nightly).

I have the same issue, the print stops, and Octoprint freeze.
I have wait few minutes to see if it unfreeze but not.
I have access to nothing even the mouse doesn't move.

So the only solution was to unplug the power cable like a barbarian (without pressing shutdown button)

I had check before starting log but after I reboot it, there 's no log.

02-26-2015, 10:55 AM
Disconnecting the Pi from the power source will corrupt your filesystem... but if you say it freezes, then you need to start excluding factors...

IIe try with other USB cables, in other PI USB ports, ssh to the pi and check the CPU usage with the top command....

It could be a faulty PI or it could be a faulty printer board.

So far I havent heard of anyone loosing total control on the "computer" controlling a Rapide LIte... so we need to go step by step here....

02-26-2015, 11:26 AM
ok, i flash the system if it was corrupt and i test as you told me then i report you
Thank Bolson

02-27-2015, 02:19 AM
I find that I have to reboot the Octopi (not restart) after turning the printer on in order for it to see it. I have to do it everytime - it boots pretty quickly so I haven't looked for a solution.

02-27-2015, 08:24 AM
In what environment clayton? Windows?

03-07-2015, 11:06 AM
Hi Bolson,

I flashed again the system, but it crashed again. in reality, it freezed.
The computer charge freezed at 44%.
I let it few minutes in order to see if it unfreeze, but not.

I have changed the USB cable, reflashed the system if it was corrup.
The same issue

I have reflashed but don't activate the camera pi, and it worked so i have a problem with the camera.

03-07-2015, 11:51 AM
Did you connect it correctly? The wiring has 2 sides... both on the camera and the pi.

03-17-2015, 11:01 PM
Hi Bolson,

I have verified, I have well connected the wires.

Perhaps there was a electrostatic discharge that broke the camera.

03-18-2015, 09:35 AM
That could be it too yes. Did you get a replacement?

03-18-2015, 11:52 AM
no, i dont get a replacement, it worked before, so it is not covered by the warantly.