PDA

View Full Version : The M$ 3D Builder Thread



TommyDee
03-31-2017, 04:46 PM
It is becoming perfectly clear that the Cube software is somehow hobbling The Qube (Cube 3).

3D Systems provided a lot of driver information and a slicer to Microsoft (M$) to support all the Cube printers 3D Systems makes and made.

Microsoft provides an SDK (https://developer.microsoft.com/en-us/windows/hardware/3d-print/sdk-app-downloads) that details how it intends to support 3D printing in their OS.
It includes a very detailed map on how you can implement your printer with driver in Windows.
If you know nothing about drivers, don't bother. But it provides some understanding of what is expected.
By default, this is installed on your Windows 10 machine. Also available for Windows8.1.
However, have the link to the SDK on hand as the driver is a bit touchy.

The reason for this thread is to get out of Cubify (or whatever the Qube app is really called) and open up some new possibilities.

Please put your love or hate in these pages.

1984

Bleky
03-31-2017, 10:10 PM
What is the driver for 8.1?3D Builder on my Windows 8.1 has no idea what to do with Cube and it is unable to find the driver for it to be able to print from 3D Builder.

TommyDee
04-01-2017, 01:43 AM
It should be the same SDK. I hadn't looked into it further, but there is info on the M$ site.

- - - - - - - - - -


What is the driver for 8.1?3D Builder on my Windows 8.1 has no idea what to do with Cube and it is unable to find the driver for it to be able to print from 3D Builder.

I remember that the SDK's install .ini files listed windows 8.1 or higher, so yes, the SDK is for Windows 8.1 also.

Bleky
04-02-2017, 08:21 AM
Still doesn't work with 8.1 but when I run it in a VM with 10 it works and sends files to the printer.
But it's Microshaft so nothing unusual...

TommyDee
04-02-2017, 05:05 PM
I'll have to see what my 8.1 does. It is a fairly straight forward system.

- - - - - - - - - -

If something simple can be made difficult, it will have M$ initials on it somewhere.

MegaloDon
04-03-2017, 07:09 AM
I seem to recall that Windows 8.1 had issues with 3D Builder that they never fixed. They did however fix it in Windows 10. Yet another way MicroShaft is trying to force you to go to Windows 10. :rolleyes:

TommyDee
04-03-2017, 03:23 PM
I cannot get the SDK loaded in Windows 8.1. It doesn't recognize it as an install file.

Bleky
04-03-2017, 06:46 PM
I cannot get the SDK loaded in Windows 8.1. It doesn't recognize it as an install file.

Damn Microshaft and their crap SDK.I can successfully install it but there is not even S of that SDK...No signs of any drivers,files and so.

TommyDee
04-20-2017, 03:54 AM
I didn't know the SDK was installed on W10 either.
I finally did a search and found it in the spool folder.

- - - - - - - - - -

And now 3D Builder errors out every time it tries to send a file to The Qube.


ARGGGG!

- - - - - - - - - -

Rebooted the computer and let The Qube go into sleep mode fixed the communication problem.

Interesting factoid; if The Qube is prompting for maintenance other that the color warning, the driver will close out in windows 10.
This lets you print and remove the USB without confusing Windooze.

- - - - - - - - - -

Another new finding about 3D Builder v. Cube s/w...

When The Qube lays down its first layer, it extrudes extra material... enough to bleed 0.25mm from the intended edge.
layer 2 may or may not do this.

Compare this to a very skimpy layer when you don't use rafts that 3D Builder lays down.

For Cube s/w, I would hack off another 50um but for 3D Builder, I would come a lot closer to the build plate.

- - - - - - - - - -

New finding... and this is useful.

The difference in height for the first layer between Cubify and 3DB is exactly one tape thickness.

DONE!

Mythandar
04-23-2017, 06:20 AM
With the latest windows 10 update there's a new program called View3D. It's a neat little program that can load the stl file to give you a quick rendered look at the model.

TommyDee
06-12-2017, 05:00 PM
You must be special, M. I cannot find it on mine and it is up to date all the time.

- - - - - - - - - -

Learned something interesting yesterday...

After adding all the filaBoat parts into 3D Builder, it output a file with the extension ".MODEL".
The .3MF file is a zip file so I wanted to know what this was.
Turns out the .MODEL extension is a XML file with a line for every triangle.

What was cool is that when I reloaded the .3mf file, it provided the option to export as .STL and OBJ.

I haven't noticed that before.

This means we can use 3DB's to make build prints and have a ready-to-print .STL based on our build plate.

MegaloDon
06-12-2017, 11:26 PM
This means we can use 3DB's to make build prints and have a ready-to-print .STL based on our build plate.
If you are talking about what I think you are, you can do the same with Meshmixer. That's how I prepare all my STL's to print. The ones I post on here are already layed out and oriented the way they need to be printed.

TommyDee
06-13-2017, 12:48 AM
MeshMixer is a little less friendly about it, but I can see that working too.

I need to compare the mesh density on the exports.

MeshMixer's display is fairly course, but I don't know if they use the original mesh or a re-meshed "optimization".

That is what I want to compare for the 3DB output version too.

One thing the new MM release did is generate some kind of floor that 3DB has to remove.
This is making MM exports a lot less friendly for me.

MegaloDon
06-13-2017, 01:40 AM
One thing the new MM release did is generate some kind of floor that 3DB has to remove.
This is making MM exports a lot less friendly for me.
Floor?? ....

TommyDee
06-13-2017, 02:16 AM
Yes, when I import a newly created STL from MM, it comes in with a transparent pink rectangle.
3DB complains and goes off to fix it for about a minute.

Just tired MM for placing. Ouch! :)

Too many ways for me to mess up a plate of parts. 3DB can't do much, so it can't do much accidentally either. :p

I like MM for supports... and I miss the old version already. This version is not tablet friendly!

bolsoncerrado
06-13-2017, 08:22 AM
I still use an MM old enough to handle 3MF and supports are basically the same...

rl.d
06-15-2017, 02:57 AM
when i connect my cube in windows10, there no happen anything, cube printer successfull instaled, i try print sdk, but still stuck. when using 3d builder, just say fail to load 3d printer capabilities,
i try to use com3 and other, still no happen,

someone can help me?

thanks a lot

TommyDee
06-15-2017, 03:29 AM
The driver gets confused. It is not a simple printer so it has to have its unique name and registered in the registry as only being available when the printer is plugged in.
I tried to edit the printer and somehow it created a second instance. This one I had to rename and then run the SDK again. I've done that several times until it took.

I use the USB on the computer and the USB-(whatever) on the right side of the Cube.
When the printer is recognized, it allows printing to it. Otherwise it just puts out a junk RAW file.

You say you installed the printer and then ran the SDK? That could have created the confusion mine was having. If you see the printer in your printer folder, don't delete it, just rename it. I think junk lingers in the registry that causes access problems. You shouldn't see the cube printer in "my printers" as installed by the SDK.

At least, that's been my experience. It works but not as robust as we are use to for other printers. This one has some hooks to keep it form being "generic".

Prematurely quitting the print driver will also cause problems. Best solution is to have the Cube display the "maintenance message" which sends a "completed" signal to the print spooler once the file is uploaded to the printer.

rl.d
06-15-2017, 05:23 AM
thanks TommyDee, still stuck now, cannot detect printer on windows 10, i try several cable, still the same

TommyDee
06-15-2017, 06:17 AM
Delete the printer in windows 10; run the SDK; connect the printer; start 3DB; open an object; run the print dialog...

In that order got me back up and running.

shawnhenson
12-30-2017, 11:31 PM
--EDIT - Sorry for resurrecting old thread

Thanks to this thread, i now have Microsoft 3d print drivers (sdk) installed. Seems to give alot more choices on the print build than cube does. Currently printing and will compare the two. Will be printing at high options on cube and MS . Will post pics here

Ill save some others the trouble and meme myself
http://www.pollplace.com/images/2010/02/04/youthinkdotcom_2892203_197930.jpg

TommyDee
12-31-2017, 12:22 AM
Hey Shawn.

Don't be fooled by those controls... they are not real.
The code is still the same and it just chooses the closest to what Microsoft wanted to have there.
But the ABS slicer is much better!

MegaloDon
12-31-2017, 02:02 AM
I wouldn't worry about resurrecting old threads. Just because they haven't been posted in for a while doesn't mean they are not still valid.

And welcome to the forum!

tprothma
01-26-2018, 08:21 AM
Hi all, I'm able to see my printer in the devices list, but I cannot seem to get it to actually print. It just errors out.

I installed 3D Builder on Win 10 64bit from MS App store (not the SDK). Am I missing some key feature by not having the SDK (instead just the app). Also I would like to print to a file. Am I missing something with the STL OBJ that allows me to directly print.

Is this helpful???
https://docs.microsoft.com/en-us/windows-hardware/drivers/3dprint/configuring-the-device
I'm missing the xml files that they are referring to.

Thanks,
Tim

TommyDee
01-26-2018, 09:23 AM
Interesting link, Tim.

M$ dug in their heels and made a 3D print driver standard that geared itself to commerce.

I had Windows 8.1 so I needed the SDK. Windows 10 came ready to roll.

The printer has to be attached in the USB-A port next to the power plug. It does not have Wi-Fi support.
When I played with it earlier it was a real handful to keep the driver working.
If you disconnected the USB you would screw up the driver by freezing the print process...
Forcing you to rerun the SDK. Windows 10 is still a bit demanding in this sense, but it appears to self-heal.
If you know where I'm coming from, you get the drift. Its a bit touchy like everything M$.

tprothma
01-27-2018, 05:55 PM
OK, still same issue. Win10 sees the printer and will try to print to the printer and it will just error out. In the printer dialog I try to connect to printer and it says "error, command not successful". I could not find any log file to dig into the error. Definitely something wrong with the driver/installation. I've tried with and without the SDK installed (unless the SDK has different drivers, no way to tell). Previously it was seeing 2 ports (USB and USB over serial). I tried with a 5 foot cable (of course connected to the USB Type B connector next to the power supply). The 3D Builder App has no revision control (nor does Win 10 for that matter). Frustrated and I'll have to find another way.

This thread is dead to me....

TommyDee
01-27-2018, 08:18 PM
I had the same thing happened. Yes, it is frustrating; yes, it doesn't make sense to code ignorant people like me.

Next time I get the print screen, I'll post what to look for.
The device is somehow "registered" and cloning it in any way will kill the driver. Took me weeks to get it back.

I like having it simply due to the fact that for me, it is the only other slicer I have, and even so, it is still the generic 3DS slicer.
However, there is a difference in the ABS algo's where 3DBuilder is a hugely improved over the Cubify app.

MegaloDon
01-27-2018, 11:12 PM
I had similar problems. The answer was much simpler for me. I just unplugged the USB from the printer and then uninstalled the print drivers. When you plug the USB back in, it should prompt to install the drivers again. This fixed it for me. You don't need the SDK.

tprothma
01-27-2018, 11:16 PM
Hi TommyDee, actually I can see the print screen, it looks like it's sending to the printer and I see the error in the print queue.
It does communicate at some level because Win10 recognizes it as a printer in the Devices and Printers list and it is able to try to spool the job to the printer from within 3D Builder. Also if the printer is looking for user input on the touch screen 3D Builder will not spool the job to the printer, instead 3D Builder or print driver will indicate that the printer is in an error state.

Anyway, I will probably try another computer, I was really intending it to be little humorous when I said this thread is dead to me...
I usually don't give up that easily anyway. But on the second computer the drivers loaded and it said "Failed to load printers capabilities" so I'll try with another cube.

Tim

TommyDee
01-28-2018, 08:27 AM
Yes, but it is spooling a RAW file to the printer instead of a .cube3.

Windows 8.1 was way worse than Windows 10. Windows 8.1 would let go of the printer if any kind of message appears on the Cube's screen. Windows 10 seems to have released the stranglehold while printing. I don't think I've put the SDK to my windows 10 machine yet. As long as I leave the device alone in windows, it behaves.

The machines -are- taking over!