Thanks Thanks:  31
Likes Likes:  18
Dislikes Dislikes:  0
Page 3 of 16 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 160
  1. #21
    Super Moderator
    Join Date
    Nov 2016
    Post Thanks / Like
    Funny... or one could just read every post in this thread

    You are very correct in dealing with this from scratch. That is the very reason for this thread.
    I am a mechanical type with a little too much knowledge of the other disciplines.

    Have you tried putting the current bootloader on a 3rd party Nano?

    I watched the routine and I understand it...
    Basically, configure a NANO as an ISP and load the current Arduino bootloader onto a properly connected NANO.
    Does that not solve the CH340 issue?

    I also noted a few pads on the NANO on the USB CH340 chip side. Any idea what those selectors select?

    I'm buying NANOs from all over China to get a good idea of variation.
    I have seen people reload the bootloader to get access to the current bootloader in the Arduino IDE.
    I didn't have to do anything with regard to loading a special CH340 driver in Windows 10.

    Once I get a decent stock of Nanos, I'll see if I can do this.

    How many do I put you down for, John?

  2. #22
    Expert 3D Printer
    Join Date
    Feb 2018
    Post Thanks / Like
    How many do you have, Tom??

    "Basically, configure a NANO as an ISP and load the current Arduino bootloader onto a properly connected NANO."

    That is above my pay grade!!

    My nano's don't appear to have any pads on either side. They are "Elegoo" brand.

    What's not ok about using the "Old Bootloader"? Why bother to burn the current bootloader?
    Last edited by JohnTee; 03-13-2019 at 11:19 PM.

  3. #23
    Super Moderator
    Join Date
    Nov 2016
    Post Thanks / Like
    Just a side hobby.

    This guy does well in explaining the process. It was a couple of these that made this whole thing make sense.

    - - - - - - - - - -

    Nano Pads

    These are often used for selectable options by either jumper or pull-up resistor.
    I'll have to ohm out where in the circuit they reside.


    - - - - - - - - - -

    I have 1 blank board, 7 stuffed boards, and a complete unit. the one going to Alex.

    - - - - - - - - - -

    I've put the first ReCube up on eBay.

    More to follow as I start receiving more Nano's.

    Let me know what you think of the ad.


  4. #24
    Expert 3D Printer
    Join Date
    Feb 2018
    Post Thanks / Like
    The ad looks very good - clear and complete description IMO. Very good deal!

    Oh, and my nano does have those pads - I just didn't know where to look...

  5. #25
    Administrator bolsoncerrado's Avatar
    Join Date
    Nov 2014
    Post Thanks / Like
    Perhaps words like Hack Free Filament or something like that in the title would help too? Dunno if ebay still focuses searches on keywords on the titles...

  6. #26
    Super Moderator
    Join Date
    Nov 2016
    Post Thanks / Like
    Once you find haxtom, I think you're there!

    - - - - - - - - - -

    This rarely happens... Today I received a second NANO from a previous order for only one Nano. Its got all the pins soldered in it making it hard to use for the ReCube.
    I'll add it to the Arduino development collection.

    - - - - - - - - - -

    The first ReCube Light Cubify Cartridge Recharge Wand sold yesterday.
    More will be coming as Nano's arrive.

    Need more eyes on the ad though. I'll see what I need some changes to make it more visible.

    - - - - - - - - - -

    Now I know where to order NANO's from. Very fast from China although later than promised.

    Got 3 more NANO's today. They're going on eBay unless someone speaks up here before I list them.

    - - - - - - - - - -

    Okay, you missed out. 3 more on the Bay.

    Couple of new images added...


    If you are the recipient of one of these devices, please introduce yourself.
    I welcome your feedback.

    - - - - - - - - - -

    ReCube Wand on CubePro Cart.jpgReCube Wand on Cube3 Cart.jpg

    - - - - - - - - - -

    Okay, and no one else caught this! Cube and Cube2 are -not- supported with ReCube! The only level of support that I am aware of is that ReCube Pro can change a Cube2 chip to a different supported chip... that's it! All that Cube2 filament harvesting did in fact yield a series of usable chips. But in general, no, the ReCube code doesn't return the right results for a new Cube2 chip.

    - - - - - - - - - -

    Interesting... got 5 more Nano's today. These have the new boot-loader. Turns out you have to increase the baud rate in the ReCube Light V2 installer batch file to 115200.

    If you do play with NANO's, new boot-loaders won't communicate when communications are set to the old boot-loader settings in Arduino IDE.

    Bottom line appears to be;
    Old bootloader... 57600
    New boot-loader 115200

    Avrdude\avrdude -C Avrdude\avrdude.conf -v -patmega328p -carduino -PCOM7 -b115200 -D "-Uflash:w:ReCube.ino.hex:i"

    - - - - - - - - - -

    Turns out the serial monitor in Arduino IDE has to be set to 115200 baud in both cases. Other settings generates gibberish in the Arduino IDE. Therefore the 57600 baud requirement is only for uploading code to the NANO if an older boot-loader is installed.

    - - - - - - - - - -

    I told you things are never as easy as they seem

    Warning, the following posting on Thingiverse is not meant for rebuilding pre-assembled ReCube Wands!
    The very nature of assembling these wands risks damaging the contacts unless you are aware as I am to know what to watch for.
    A similar note applies to disassembly.
    However, if you picked up one the kit offerings in this series of posts, you might want to check these prints out on Thingiverse.
    Happy to walk anyone through the required assembly precautions. (maybe I need an assembly 3D printed jig to make this simple also.)

    - - - - - - - - - -

    CubePro and Cube3 cartridge recharge procedure. Note that the wand is one of the current bootloader versions. Boots a lot faster for some reason. That is my hesitation in the video.

    - - - - - - - - - -

    Alrighty then... And we played with the bootloader thing.

    I am so glad I didn't overthink the connection regime because I am finding all kinds of errors on diagrams on the web.

    1st of all, I followed the advice from the video linked above. Worked like a charm!
    Considering I had only one NANO with the current bootloader, and I really need to build it into a ReCube Wand, I needed to get this done.

    I did do the homework part of finding confirmation for the pin-out, and even had it make sense before continuing.

    Pretty simple on the wiring. Considering pins are broken out all over the board, you have options.

    In order to update a bootloader from a Master [Programmer] to a Slave [Target], the following 6 signals need to be connected assuming you are using the USB power source:

    GND to GND
    +5V to +5V
    D11 to D11 [MOSI]
    D12 to D12 [MISO]
    D13 to D13 [SCK... clock]
    and this is the one that matters;
    D10 [Master] to RST [Slave]

    After looking through the actual layout of the NANO board, it is clear that there are hard wired traces between the edge headers and the 6-pin header.
    I did not use the 6-pin header for programming because the other pins are marked much better and were easier to access considering I had no pins installed.

    However, if you want to use the 6 pin header, it is appropriate for the Slave [Target] NANO.
    At some point, I will design a programmer case to do this. Already got some spring loaded test pins on the way.

    The 6-pin header is numbered from the dot on the silkscreen:

    Pin 1 is connected to D12 [MISO]
    Pin 2 is connected to +5V [USB power from the Master only!]
    Pin 3 is connected to D13 [SCK]
    Pin 4 is connected to D11 [MOSI]
    Pin 5 is connected to RST [reset on the schematic]
    Pin 6 is connected to GND

    This is one for one ex​cept for pin 5 which goes to the Master's D10 pin.

    I recommend you follow the logic of the Arduino IDE as clearly explained in the video.
    One thing that is easily forgotten, since Arduino IDE maintains previous settings...

    So the procedure is too easy... in some ways.
    Here's the logic: ...and remember, I tested this from a current bootloader perspective on the Master!

    The Master NANO needs a sketch uploaded to it.
    You are loading the example sketch: File/Examples/11.ArduinoISP/ArduinoISP to the Master NANO.
    Everything can be connected when you go through this process:
    When you open the sketch, a new window will open up from which you will upload the sketch to your current bootloader NANO.
    Be sure the settings in Tools are on the right COM port and the Processor is ATmega328P; programmer at this point should be ArduinoISP.
    Upload the sketch to your Master.
    Back to tools/Programmer and pick [Arduino as ISP].
    Then Tools/Burn Bootloader. This takes mere seconds! And the message will confirm success.
    Reset the Tools/Programmer: back to ArduinoISP so next time things are normal again.

    You now have two current bootloader NANO's ready for their new code.

    I did take it one more step. I did take the newly burned NANO and tested that I could upload a sketch using the current bootloader setting, and it took a my ReCube test program and worked fine with a ReCube Shield.
    From there I went back through the entire procedure, rebooting Arduino IDE just in case, with the newly updated bootloader NANO to make sure it would also function in this same way. I put away the one NANO I started with and wired up the newly configured NANO to update a 3rd NANO with an old bootloader. Worked just as well on my 3rd development NANO. I now have 3 NANO's with current bootloaders. This last NANO was running a test program for a few days already... and I reloaded the test sketch [environmental monitor], plugged it in, and no one is the wiser.

    Now I have one more ReCube to I can build without worrying about letting that one and only current bootloader unit go.


    After a few more tests, I did check that installing ReCube Light would be consistent with previous findings.
    Indeed, the install of ReCube light did require a 115200 baud rate in the batch file.
    And ReCube Light worked as expected on a cartridge chip.

    A quick note on an interesting finding when using ReCube or ReCube Light... the COM window baud rate must be set to 115200. This is set within the ReCube code. If you get garble in the COM window using ReCube or ReCube Light, you probably have communications set to 9600 baud from some other experiment.

    - - - - - - - - - -

    ...And a new day. Today I should see the next PCB order in the mail.
    I went through the Nano programming this morning including installing new bootloaders.
    That is a process that I definitely need to streamline with the spring loaded pins when they get here.
    Also had one Nano fall out on the last order with a damaged D13 LED.
    Good thing there are plenty on order.

    - - - - - - - - - -

    Slimline ReCube Shield


    I wondered if this would work.
    No accidental reset switch access; Nano lights shielded by the shield board; <9mm overall thickness.

    Yep, it worked...


    ...4 pins, 2 resistors and a little finesse.

    - - - - - - - - - -

    Alright peeps. Those lurking and the hardy readers of this thread... I have a few extra ReCube Shield boards on hand that I will offer up for sale.

    $5 for the bare board.
    $8 includes the board, I'll install the two required 0805 resistors; R1, 100K for D4 pull-down and R4, 2.2K for A0; the pull-up for one-wire write operation.
    This includes me mailing the board via USPS postal mail (one forever stamp, an envelope, PayPal charges).
    EU/UK/and elsewhere, we can discuss your best shipping options.
    The case is already offered up on Thingiverse but your welcome to make it your own.

    I provide the basic board and you add the contacts you like... A couple of pins, wires, or clips... whatever.
    The board has 2 pads and 2 holes to do with as you like for making chip contact.
    You also provide the NANO and programming.
    What you don't get or need is the flashing lights and the switch. Most Nano's are provided with more than enough pins but I will include a set if you ask for them.

    This is more for the peeps wanting the Pro version of ReCube and have the experience to make this work from the computer and really don't need my one-button eBay offering.
    Of course I can offer the full ReCube Light Wand as on eBay for $25 (a $4.50 savings). First class mailing will be $4 (another $1 saved) within the USA.

    If there is enough call for it, I can do kits or sub-assemblies beyond this. Breaking up inventory beyond this offer would be problematic for the short term.

    Not spamming you guys! Just making the offer and covering my @$$.

    - - - - - - - - - -

    Finally my Nano stock outnumbers my prepared ReCube shields.
    This latest repeat order from this supplier also yielded 100% new bootloaders.
    And his price is very reasonable! Took 3 weeks from China. Also respectable!
    Delivered with gold plated pins too.
    Just a shout-out. Your mileage may vary.
    Last edited by TommyDee; 04-15-2019 at 05:22 AM.

  7. Thanks bolsoncerrado thanked for this post
  8. #27
    3D Printer Noob
    Join Date
    Apr 2019
    Post Thanks / Like
    Hi All

    New to the forum. Just bought a Cubepro Due and was well pleased until I realised how expensive the refills are. Luckily there are people like Tomuro who have took the time to get around this with his expertise and programming skills. Thanks to Tommy Dee for introducing me to the forum.

    I originally had V2.02 on the Cubepro and as detailed have successfully flashed V2.00 and uploaded the new firmware. This is working great as far as I can tell. The cartridges are staying on 97% and 1% respectively.

    I have made a spool holder to take a 1kg Pla spool and removed the Cubepro Cartridge. I also made a chip holder which also works great. (See attached Image) This allows you not to have the cube filament in at all.

    Since swapping over to the new PLA filament I'm having an issue where the program runs for about 20% of the cycle then throws an error F11 or F12. Both relate to cartridge blockage. Just to eliminate the possibility of the extruder not being able to pull from the heavier reel, I have tried pulling a load of slack off the spool so there is no resistance at all but the same error still occurs. I think this could be to do with the chip settings being for ABS and the filament being PLA? Not sure if this is the right question to ask on this particular issue but feedback would be appreciated.

    I'm hoping to build Tomuro's chip resetting tool. Will this be able to change the filament type from ABS to PLA or will I need to buy a PLA cartridge?
    The nozzle temp setting only go down to 210c whilst using ABS and from what I've read PLA needs to be more like 180c?

    Many Thanks In advance.


  9. #28
    Super Moderator
    Join Date
    Nov 2016
    Post Thanks / Like
    Welcome to the forum, Mick!

    You must also be using the temperature modifier to get the PLA to work with an ABS chip. Cube3 prints PLA at 215C and the first layer up at 235C. It would be much simpler to just have PLA chips handy for PLA. I find that these temperatures work just fine with most standard PLA filaments.

    One quick question... how did you force your machine to accept the downgrade to 2.00 from 2.02? That is for another forum member having trouble getting this to work.

    As to Tomuro's code, the Light version will let you simply charge the chips to 100% without an app like Arduino IDE (serial monitor) but if you do have a serial interface running, you can change the chips to a lesser percentage for the modified code.
    The Pro version or ReCube will let you change chip type and machine types. With help, I've recovered several Cube and Cube2 chips to make Cube3 chips. You have to contact Tomuro for a quote on the upgrade and he will email you a personalized Pro version of the code.

    I am not sure what is going on with the errors. I do know that these machines can do current sensing on the stepper motors. I have not run PLA in my CubePro as yet. Is it possible you are running a filament that is harder than normal run of the mill PLA? Like Cube3, CubePro uses a fixed gap for the filament drivers. A hard filament may trigger the current sensing throwing the error.

    Unlike the Cube3, the CubePro plays all kinds of games with the print. I noticed that ABS goes to 260C for most prints, but solid prints goes to 250C. Seeing how we cannot take apart the v2.0x prints to examine, it is hard to say what is going on inside the print file. The latest version of the app that we can take apart the print files of is V1.87. The machine can still be v2.0n to run this backdated slicer. Personally, I was not that impressed with this older slicer.

    Looking forward to seeing your ReCube build

    - - - - - - - - - -

    Sneak Peek on my bootloader updater for the Nano's going into ReCube Wands:


    The CubePro does impress for technical parts like this. This is 3DS ABS.

    - - - - - - - - - -

    And those pins work nicely here since I have a 'few' extras:

    Last edited by TommyDee; 04-23-2019 at 03:27 AM.

  10. #29
    3D Printer Noob
    Join Date
    Apr 2019
    Post Thanks / Like
    Quote Originally Posted by TommyDee View Post
    Welcome to the forum, Mick!

    You must also be using the temperature modifier to get the PLA to work with an ABS chip. Cube3 prints PLA at 215C and the first layer up at 235C. It would be much simpler to just have PLA chips handy for PLA. I find that these temperatures work just fine with most standard PLA filaments.

    One quick question... how did you force your machine to accept the downgrade to 2.00 from 2.02? That is for another forum member having trouble getting this to work.

    Attachment 3236
    Attachment 3237

    I will contact Tomuro for a quote on the files. I am running the nozzle temperature at 210c. That's as low as it will go. I'll order a spool of (Non 3d systems ABS) and test to see if that works without error. At least then I'll know if its a PLA issue.

    I downloaded V2.02 from 3d systems and saved to a usb (Thumb drive). I then Downloaded V2.00 off this forum and saved to another Thumb drive.
    I first tried flashing version V2.00 straight to the Cube Pro but it kept rejecting. I also tried saving V2.00 as V2.02 but still did not work.

    I then did a firmware update using the thumb drive with V2.02 on it but pulled the thumb drive out after it had started uploading (About 10 secs not even on 1%). I then inserted the version V2.00 renamed as V2.02 and pressed retry. Everything worked great and actually says it has V2.00 loaded.

    This method has already been spoken about on the forum so not my great idea. LOL.

    Is there a email address for Tomuro? I'm a little nervous of the links on his site the anti virus is going mad!!


  11. #30
    Super Moderator
    Join Date
    Nov 2016
    Post Thanks / Like
    I'm pretty sure it <= confirmed. You can let him know about the download site too I've done my share of highlighting it.

    I've been to the site quite a few times without issue. As long as you have virus protection, it should be fine. I have Norton and yes, it lights up light a xmas tree.

    Okay, that is what the other user did also but it failed for him. We might go another route that I know worked on Cube3. I know 3DS has some codes you can force the printer to do things. They want you beholden to their service techs... which of course is probably down to one person and a large echo chamber.

    I like 3D Solutech for an alternate PLA filament. You might have some favorites too. As to ABS, be careful. I noticed that 3DS ABS really is a special formula... one that runs 10C hotter. Learned this through many failures in Cube3 until I dialed the temperature down. I got a lot of popping and spitting, and it wasn't moisture... it was simply too hot. CubePro may act differently, but I don't see how. Best profile I've found for 3rd party ABS is Ekocycle (PETG) which CubePro doesn't support.

    In the long run, I hope to modify the CubePro config files. This will bring recipe making to the CubePro. Managing the config files is the biggest challenge. Some kind of up-front menu will be needed to know what you are currently running.

    - - - - - - - - - -

    oh, D'uh! You have the temp modifier. 3rd party ABS between 245C and 250C works great. 3DS ABS, 260C.

    I will also avoid putting 3DS metallic ABS filament in CubePro. In Cube3 it showed a "skin" on the filament for the metallic highlighting. This stuff makes a mess of nozzles in fairly short order. If I swap it out after a print, it bleeds out, but if I print and print with the silver, it becomes clogged. ...and I don't get clogs in Cube3 anymore!
    Last edited by TommyDee; 04-23-2019 at 01:19 AM.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts