Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    3D Printer Noob
    Join Date
    Mar 2019
    Posts
    1
    Post Thanks / Like

    CR10S pro bed leveling

    Hello All,

    I have been trying to level the bed for my new CR10s pro for more than a week now and it has started to get very very frustrating. i have scratched my surface in the process, have a hole in the bed, a lot of wasted material.
    Here is what is going on:
    1. even though i did my Aux leveling and auto level, i have to offset the print by 0.35mm everytime.
    2. the left side is always higher and closer to the nosel than the right side.
    3. I added autolevel in the slicer as well, but that didnt change it either.

    I have tried leveling like a million times and everytime i have this issue.
    I also noticed something, that my z-axis level is also not good. everytime i set the level on z-axis, i feel the wheel moving down and changes the level. But regardless of that, if the autolevel would work, that should compensate the problem.
    As far is the print is small and centered, it will work alright, any big print will mess up everytime.

    and dont even get me started when printing with ABS. Total waste.

    Any help will be appreciated.

    Thanks

  2. #2
    Super Moderator
    Join Date
    Nov 2016
    Posts
    3,396
    Post Thanks / Like
    Welcome to the forum, ammarqs.

    I do not have a CR10S so I am not familiar with the leveling process.

    Are you certain that your build plate is true flat?
    That would be the 1st thing to confirm. Even my small printers use beds that are not completely flat.

    Is the auto-level a routine that remains with the printer? I mean, does the printer compensate for tilt in software/firmware by changing Z-height while printing?
    Or is the CR10S auto-level simply a routine to get you to a level bed?

    You should be able to do this manually. Raise the bed close to the nozzle and use a gap gauge of some kind. Move the bed and nozzle until all 4 corners exhibit nearly the same gap. If you have to compensate your prints by 0.35mm, make the gauge at least this thick. (normally you can do this in your slicer).

    If your levelers are not holding tight, you might consider a few more spacers to really make that spring force work for you.
    Again, not knowing exactly what these look like, I can only offer limited solutions.

    The part about auto-leveling with z-compensation is a real pain. My Cube3 printers use auto-leveling in firmware. This means that I cannot zero out the plate. The built-in compensation does not agree with a true leveling of the plate. I can hear the compensation as the nozzle traverses the plate. you hear these "ticks" that is Z adjusting itself while printing. The only way I can negate this action is to zero in on a level plate where no Z-compensation is required. When I run the auto-level routine for the last time, there is no compensation in either X or Y all the way to the extent of the bed. Now I know I am mechanically and electronically perfectly level.

    I go through this process only in that auto-z compensation does show up as an artifact in the print. It might make setting up a printer easier, but some of us simply are not wired to accept "good enough".

    Again, your CR10s may use a different system so please take away only that which is applicable to your machine's way of working.

  3. #3
    3D Printer Noob
    Join Date
    May 2022
    Posts
    1
    Post Thanks / Like
    The printer has a port tied to it and as long as it remain untouched, it will remain valid. As soon as you go to the printer's properties, it removes the port and it now stand in the way with the name the real print driver needs. The only fix I've found so far is to go to Microsoft and repair the SDK for 3DB.

  4. #4
    Super Moderator
    Join Date
    Nov 2016
    Posts
    3,396
    Post Thanks / Like
    You've got all that right @Gwyneth You can't pull up its driver. That is what invalidates the link. Reinstalling the patch is the only way to reset it. Not very well implemented but it was early on in the game and Micro$oft was eager to hold this transaction space.

    I have a different printer but exactly the same behavior from the driver.

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •