Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 10 of 11 FirstFirst ... 891011 LastLast
Results 91 to 100 of 102
  1. #91
    Administrator bolsoncerrado's Avatar
    Join Date
    Nov 2014
    Posts
    3,325
    Post Thanks / Like
    Did you enable the webcam using sudo raspi-config ?

  2. #92
    3D Printer Noob
    Join Date
    Dec 2014
    Posts
    11
    Post Thanks / Like
    I'm using a USB camera, which works great inside my network. It's the routing outside that's an issue.

  3. #93
    Administrator bolsoncerrado's Avatar
    Join Date
    Nov 2014
    Posts
    3,325
    Post Thanks / Like
    Thats because octopi comes presetup for the raspi camera... you may need to edit the HTML/PHP code for the website to use your IP cam URL instead.

  4. #94
    Expert 3D Printer
    Join Date
    Dec 2014
    Posts
    305
    Post Thanks / Like
    You just need to figure out what is the port of the camera stream and open it also in the router.
    The url of the video stream at the octoprint settings needs also to be the external DNS name and not the localhost.

  5. #95
    Regular 3D Printer
    Join Date
    Dec 2014
    Posts
    174
    Post Thanks / Like
    Can any of you guys post what settings you used in octoprint? Not sure about my connection but I currently do not have the extruder mounted. I get an error code 0: extruder switched after getting multiple server offline attempts. I am assuming this is due to the lack of the extruder? Please help if you can....

    edit: checked serial log and it appears connection gets closed since "extruder is switched off and mintemp error occurs. Need to get eh extruder rebuilt and put back on to test.
    Last edited by Skinny Kid; 02-10-2015 at 05:30 AM.

  6. #96
    Regular 3D Printer
    Join Date
    Dec 2014
    Posts
    174
    Post Thanks / Like
    So I tried tried to connect with octoprint after installing extruder. All I get is server offline, cannot make any connection regardless of whether I leave setting alone or change them. Now can't even access Octoprint....got bad gateway error to start and now it says cannot find it....pi is powered on.

    This is amazing what a pain this is. Everything that supposed to be easy is nothing but frustrating. Any ideas?

  7. #97
    Regular 3D Printer
    Join Date
    Dec 2014
    Posts
    157
    Post Thanks / Like
    Reinstall OctoPi onto the microSD and try again. Might work.

    Have you made any port forwarding on your router yet?

  8. #98
    Regular 3D Printer
    Join Date
    Dec 2014
    Posts
    174
    Post Thanks / Like
    I have not mad any port forwarding on my router? Can I ask where it says to do that?

    Reinstall Octoprint because it might work? lol I thought it worked like a charm.....

  9. #99
    Administrator bolsoncerrado's Avatar
    Join Date
    Nov 2014
    Posts
    3,325
    Post Thanks / Like
    Octoprint does work like a charm... once you have it running

    With Raspberry/Raspbian/Octopi, you can't unplug the raspberry while it's running or you collapse the filesystem...

    And you only need to open ports if you want to access it from the outside (of your LAN). OTherwise, no, you dont need to open any ports, just open your browser in your computer and open octopi.local url.

  10. #100
    Regular 3D Printer
    Join Date
    Dec 2014
    Posts
    174
    Post Thanks / Like
    Can I ask why wouldn't I connect to printer when I had it running? All I kept getting was Server offline response as it connected. I had to disconnect to get the "server offline" message to stop as it kept trying.

    Not trying to access outside of my LAN....so haven't done anything with ports. Cannot connect with octopi.local...says it cannot be found. So reinstall octoprint is the next step?

 

 

Similar Threads

  1. OctoPrint/OctoPi Profile for Rapide Lite 200
    By Rep3D in forum Rapide Pi
    Replies: 3
    Last Post: 07-06-2015, 01:28 PM
  2. Octoprint or Astroprint?
    By Skinny Kid in forum 3D Software
    Replies: 23
    Last Post: 03-17-2015, 01:03 PM
  3. PrintToPeer: Print in the Cloud with a RaspBerry Pi
    By bolsoncerrado in forum Rapide Pi
    Replies: 0
    Last Post: 02-04-2015, 09:26 PM
  4. PrintToPeer: Print in the Cloud with a RaspBerry Pi
    By bolsoncerrado in forum 3D Software
    Replies: 0
    Last Post: 02-04-2015, 09:26 PM
  5. Octoprint setup with Raspberry Pi
    By JonatanJacobsson in forum Rapide Lite 3D Printers
    Replies: 31
    Last Post: 01-12-2015, 08:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •