I have had a CR-10 for several years and have'nt used it since last year. A few days ago i needed to print something and it would not print. At first I thought it was a blockage in the extruder hot end but after several attempts at cleaning and replacing the nozzle found that this wasn't the problem.

I tried several other things and eventually discovered that the Extruder stepper motor wasn't turning when using the Move axis on the Control Panel, I thought that the cable had been damaged so swapped with the X-axis cable. The Extruder stepper motor turned when the X-axis was moved from the Control Panel.

I then opened the Control Box and swapped the Extruder cable onto the X-axis and the X-axis worked. The X-axis cable didn't work on the Extruder axis , so I suspected a problem on the Main Board. I bought a replacement Board and fitted it. The same problem still existed. I tried all the previous tests and changes to no avail. The problem looks as though it is not with the Main Board at all.

Is there anything i have overlooked? Has anybody had the same problem? Can anybody help?

I hope that I've made myself clear as I can't think of any solution I haven't tried.