Thanks Thanks:  2
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 10 of 10
  1. #1
    3D Printer Noob
    Join Date
    Oct 2021
    Posts
    5
    Post Thanks / Like

    CubePro Duo Firmware (Original)

    Hey All,

    What a cracking forum! I have just purchased a second hand CubePro Duo that has been running your hacked firmware but am experiencing the usual chamber heater issue.

    I have just purchased a cartridge re-set tool and a chip holder so that I can put it back onto the original firmware and just reset the chip counter.

    Im struggling to find the original and latest firmware for the printer? I have memory stick with V2.02 on it which I assume is the hacked version? Could someone point me in the right direction for the original standard firmware? I thought I had found it on the 3DS Cube File Links page but it didnt work?

    Cheers
    Andy

  2. #2
    Super Moderator
    Join Date
    Nov 2016
    Posts
    3,348
    Post Thanks / Like
    We have the Cubify repository stored among us.

    http://www.print3dforum.com/showthre...ube-File-Links

  3. #3
    3D Printer Noob
    Join Date
    Oct 2021
    Posts
    5
    Post Thanks / Like
    Hey Tommy,

    Cheers for the fast reply!

    You will have to excuse my lack of knowledge on these beasts. Which file is it that I actually need?

    It looks like cubepro_v1.10.ar is the latest but it didnt work?

    Cheers

  4. #4
    Super Moderator
    Join Date
    Nov 2016
    Posts
    3,348
    Post Thanks / Like
    There should be a version 2.02. Yes, .ar is the right extension and cubepro is the appropriate prefix.

  5. #5
    3D Printer Noob
    Join Date
    Oct 2021
    Posts
    5
    Post Thanks / Like
    Cheers Tommy. Think I've finally got it to work.

    The fan for the chamber heater starts up as soon as I turn the power switch on but when I go to print a model and it says 'heating' I can't feel it getting warm at all. I put a fan heater in the printer and hey presto it started loading.

    Has the heater got a fuse or trip? It used 1% of material so I definitely don't have the hacked firmware on it anymore?

  6. #6
    Super Moderator
    Join Date
    Nov 2016
    Posts
    3,348
    Post Thanks / Like
    The fan on the heater is on all the time but the heater has a thermal fuse internally to stop heating. Technically, it should be hardwired to the AC input.

    I am not sure anyone has investigated what the hack did to the heater. If yours failed for some reason, then the hack is highly suspect.

  7. #7
    3D Printer Noob
    Join Date
    Oct 2021
    Posts
    5
    Post Thanks / Like
    Quote Originally Posted by TommyDee View Post
    The fan on the heater is on all the time but the heater has a thermal fuse internally to stop heating. Technically, it should be hardwired to the AC input.

    I am not sure anyone has investigated what the hack did to the heater. If yours failed for some reason, then the hack is highly suspect.
    So should it start heating as soon as I turn it on?

    Does the hack break the heater for good? Im trying to go back to standard.

    - - - - - - - - - -

    Ive managed to get it back to Firmware v2.00 but still no heating.

    Do you think I have a broken heater? Or should I now try and re-flash with the latest v2.02? I dont know which is the best/most stable firmware to be running.

    Cheers

    - - - - - - - - - -

    Well..... got to the bottom of why the heater wont work!!

    Anyone in the UK with spares? Or with access to a board that could tell me what value the capacitor was?

    CheersBlown Board.jpg

  8. #8
    Regular 3D Printer
    Join Date
    Sep 2018
    Posts
    95
    Post Thanks / Like
    Yes, look at the next post down I know he's already moved the printjet assembly but I bet he still has this.


  9. Thanks Skinnerpot thanked for this post
  10. #9
    Super Moderator
    Join Date
    Nov 2016
    Posts
    3,348
    Post Thanks / Like
    Quote Originally Posted by Skinnerpot View Post
    So should it start heating as soon as I turn it on?

    Does the hack break the heater for good? Im trying to go back to standard.

    - - - - - - - - - -

    Ive managed to get it back to Firmware v2.00 but still no heating.

    Do you think I have a broken heater? Or should I now try and re-flash with the latest v2.02? I dont know which is the best/most stable firmware to be running.

    Cheers

    - - - - - - - - - -

    Well..... got to the bottom of why the heater wont work!!

    Anyone in the UK with spares? Or with access to a board that could tell me what value the capacitor was?

    CheersBlown Board.jpg
    The only posts we've seen about failed heaters was after the hack so I bet it is the culprit. Not sure how it would do that though. Somewhere in the firmware is where the chamber temperature is managed.

    I also suspect the device is a MOV - a sort of voltage spike suppressor.
    Last edited by TommyDee; 10-26-2021 at 05:56 PM.

  11. #10
    3D Printer Noob
    Join Date
    Oct 2021
    Posts
    5
    Post Thanks / Like
    Thanks for all the help! The component was a current limiter. I have ordered a second hand control board from ebay and will test the heater element before fitting.

    I do wonder if these components are running at their limit as even the replacement board has some heat damage/markings around the limiter!

    Something for other people to check if they are having heater problems, its very easy to access.

  12. Thanks TommyDee thanked for this post
 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •